スイッチ基本操作

スイッチ基本操作

スイッチもルータと同じくIOSが搭載されており、基本はIOS上で動作することになります。
IOSのバージョンやイメージファイル名などは、show versionコマンドで確認できます。

C2950-12A#show version
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA13, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by cisco Systems, Inc.
Compiled Fri 27-Feb-09 22:20 by amvarma
Image text-base: 0x80010000, data-base: 0x80570000

ROM: Bootstrap program is C2950 boot loader

C2950-12A uptime is 2 minutes
System returned to ROM by power-on
System image file is "flash:/c2950-i6q4l2-mz.121-22.EA13.bin"

cisco WS-C2950-12 (RC32300) processor (revision R0) with 20957K bytes of memory.
Processor board ID FOC0913Z1F9
Last reset from system-reset
Running Standard Image
12 FastEthernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:13:C3:54:88:80
Motherboard assembly number: 73-5782-13
Power supply part number: 34-0965-01
Motherboard serial number: FOC0913131H
Power supply serial number: DAB09104CRD
Model revision number: R0
Motherboard revision number: A0
Model number: WS-C2950-12
System serial number: FOC0913Z1F9
Configuration register is 0xF

オレンジ:IOSバージョン
ブルー:IOSイメージファイル名
グリーン:コンフィギュレーションレジスタ値

IOS上で動作することになりますので、やはりルータと同じでモードがあります。


各モードへの遷移コマンド
ユーザーモード コマンドなし
Switch>

特権モード enableコマンド
Switch>enable
Password
Switch#

グローバルコンフィギュレーションモード configure terminalコマンド
Switch#configure terminal
Switch(config)#

インターフェイスコンフィギュレーションモード interfaceコマンド
Switch(config)#interface fastEthernet0/1
Switch(config-if)#


コンフィギュレーション(設定)の確認

コンフィギュレーションの確認もルータと同じでshow running-configコマンドで行えます。

C2950-12A#show running-config
Building configuration...

Current configuration : 1870 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname C2950-12A
!
enable password cisco
!
clock timezone JST 9
ip subnet-zero
!
!
!
spanning-tree mode rapid-pvst
spanning-tree loopguard default
spanning-tree portfast default
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
 switchport access vlan 100
 switchport mode access
 duplex full
!
interface FastEthernet0/2
 switchport mode trunk
 duplex full
!
interface FastEthernet0/3
 switchport access vlan 100
 switchport mode access
 duplex full
!
interface FastEthernet0/4
 switchport access vlan 100
 switchport mode access
 speed 10
 duplex full
!
interface FastEthernet0/5
 switchport access vlan 110
 switchport mode access
 duplex full
!
interface FastEthernet0/6
 switchport access vlan 110
 switchport mode access
 duplex full
!
interface FastEthernet0/7
 switchport access vlan 110
 switchport mode access
 duplex full
!
interface FastEthernet0/8
 switchport access vlan 110
 switchport mode access
 speed 10
 duplex full
!
interface FastEthernet0/9
 switchport access vlan 120
 switchport mode access
 duplex full
!
interface FastEthernet0/10
 switchport access vlan 20
 switchport mode access
 duplex full
!
interface FastEthernet0/11
 switchport access vlan 10
 switchport mode access
 duplex full
!
interface FastEthernet0/12
 switchport mode trunk
 speed 10
 duplex full
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan100
 ip address 141.108.100.10 255.255.255.0
 no ip route-cache
!
ip default-gateway 141.108.100.1
ip http server
!
line con 0
 exec-timeout 120 0
line vty 0 4
 exec-timeout 120 0
 password cisco
 login
 transport input telnet
line vty 5 15
 exec-timeout 120 0
 password cisco
 login
 transport input telnet
!
!
end

コンフィギュレーションの保存方法に関してもルータと同じです。
 → コンフィギュレーション(設定)の表示と保存
 → copyコマンド詳細


このように、基本的な操作方法はルータと変わりありません。
ただ、スイッチ特有のコマンドや概念がありますので、本カテゴリでは、その部分を中心に紹介していきます。

タグ