スタティックルーティング

スタティックルーティング

スタティックルーティングはネットワーク管理者が手動で各ルータのルーティングテーブルを作成し経路を決定させる方法です。
小規模なネットワークではその利点を発揮できますが、中規模以上となると欠点が利点を上回ることが多いのが特徴です。

スタティックルーティング利点
  • ルータのCPUオーバヘッドがない。
  • ルータ間の帯域を消費しない。
  • セキュリティ向上。
スタティックルーティング欠点
  • ネットワーク規模が大きくなるとルート設定が困難であり手間である。
  • ネットワーク構成の変更時にも手動で変更しなくてはいけない。
  • 障害発生時、自動的に代替ルートに切り替えることができない。

スタティックルーティング設定

スタティックルーティングの設定はip routeコマンドを使用します。
実際に、下図のようなネットワークをスタティックルーティング設定で構築してみます。

ネットワーク構成


今回はルータを3台使用し、「PC A」から「PC B」に対してpingが成功することを目指します。
まずそれぞれのルータのインターフェイスに対してIPアドレスを設定します。

RouterAにIPアドレスを設定
RouterA(config)#interface fastEthernet 0
RouterA(config-if)#ip address 172.16.0.200 255.255.0.0
RouterA(config-if)#no shut
RouterA(config-if)#exit
RouterA(config)#interface ethernet 0
RouterA(config-if)#ip address 172.31.0.200 255.255.0.0
RouterA(config-if)#no shut

RouterB、RouterCも同様に設定します。

続いて、スタティックルートを追加し、ルーティングテーブルを作成していきます。
まず、何も設定していない状態でRouterAのルーティングテーブルを表示してみます。
ルーティングテーブルはshow ip routeコマンドで表示できます。

RouterA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    172.16.0.0/16 is directly connected, FastEthernet0
C    172.31.0.0/16 is directly connected, Ethernet0

RouterAは「172.16.0.0/16」と「172.31.0.0/16」のネットワークを理解しています。
黄色い網掛け部分の行の先頭に”C”というアルファベットが記載されています。
“C”は「connected」を表しており、そのネットワークに直接接続されているということを意味しています。
この段階では、RouterAは「192.168.0.0/24」と「192.168.1.0/24」のネットワークの存在を知りません。
もしRouterAに宛先アドレスが上記どちらかのネットワークを指していた場合、RouterAはその届いたパケットをどこに送れば良いのかわからないため、そのまま破棄してしまいます。

では、RouterAにそれらのネットワークに向けたパケットが届いた場合、どこにパケットを転送すれば良いのかを指示してやります。そのとき使用するのがip routeコマンドになります。

RouterA(config)#ip route 192.168.0.0 255.255.255.0 172.16.0.100
RouterA(config)#ip route 192.168.1.0 255.255.255.0 172.31.0.100

ip routeコマンド書式
(config)#ip route [ネットワークアドレス] [サブネットマスク] [インタフェース | ネクストホップ] {管理距離} {permanent}

ここでもう一度、ルーティングテーブルを確認してみます。

RouterA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    172.16.0.0/16 is directly connected, FastEthernet0
C    172.31.0.0/16 is directly connected, Ethernet0
S    192.168.0.0/24 [1/0] via 172.16.0.100
S    192.168.1.0/24 [1/0] via 172.31.0.100

先頭に”S”がついた(水色で網掛けした)2行が追加されています。
“S”は「static」を表し、スタティックルートを意味します。

RouterB、RouterCも同様に直接接続されていないネットワークのパケットが届いた場合の転送先を指示してやります。

RouterB スタティックルート設定
RouterB(config)#ip route 172.31.0.0 255.255.0.0 172.16.0.200
RouterB(config)#ip route 192.168.0.0 255.255.255.0 172.16.0.200

RouterB show ip routeコマンド出力結果
RouterB#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.16.0.200 to network 0.0.0.0

C    172.16.0.0/16 is directly connected, FastEthernet0
S    172.31.0.0/16 [1/0] via 172.16.0.200
S    192.168.0.0/24 [1/0] via 172.16.0.200

RouterC スタティックルート設定
RouterC(config)#ip route 172.16.0.0 255.255.0.0 172.31.0.200
RouterC(config)#ip route 192.168.0.0 255.255.255.0 172.31.0.200

RouterC show ip routeコマンド出力結果
RouterC#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.31.0.200 to network 0.0.0.0

S    172.16.0.0/16 [1/0] via 172.31.0.200
C    172.31.0.0/16 is directly connected, Ethernet0
S    192.168.0.0/24 [1/0] via 172.31.0.200

これで設定は完了です。
では、「PC A」から「PC B」にpingを送信してみます。

C:\Users\gran>ping 192.168.1.1

192.168.1.1 に ping を送信しています 32 バイトのデータ:
192.168.1.1 からの応答: バイト数 =32 時間 =1ms TTL=255
192.168.1.1 からの応答: バイト数 =32 時間 =1ms TTL=255
192.168.1.1 からの応答: バイト数 =32 時間 <1ms TTL=255
192.168.1.1 からの応答: バイト数 =32 時間 <1ms TTL=255

192.168.1.1 の ping 統計:
    パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、
ラウンド トリップの概算時間 (ミリ秒):
    最小 = 0ms、最大 = 1ms、平均 = 0ms

無事にecho応答が返ってきています。
※もしpingが通らない場合は、show interfaceコマンドなどで問題箇所を探っていくことになります。ここで多いミスとしてはルータ―ルータ間、ルータ―PC間をストレートケーブルで接続していることです。(AUTO-MDIX機能が搭載されているルータ機種の場合はストレートケーブルでもつながりますが、搭載されていない場合はつながりません。)ルータ―ルータ間、ルータ―PC間はクロスケーブルを使用します。

タグ